Difference between revisions of "Installation"

From The DarkMod Wiki
Jump to navigationJump to search
m (add linux notes about doom3 and 64 bit systems)
Line 1: Line 1:
 
== Requirements ==
 
== Requirements ==
  
In order to install The Dark Mod, you need to have the 1.3.1 patch for Doom 3 installed. You can download the patch [http://208.49.149.118/TheDarkMod/Files/DOOM3-1.3.1.exe here].
+
In order to install The Dark Mod, you need to have the 1.3.1 patch for Doom 3 installed. You can download the patch for Windows [http://208.49.149.118/TheDarkMod/Files/DOOM3-1.3.1.exe here].
  
It is recommended that the installation path for Doom 3 contains no blanks as it might cause problems with some of the tools. Additionally it is recommended to keep all the paths lower case. This is especially important as Doom 3 can also run on other platforms like Linux where pathnames are different depending on their case (i.e. /home/sparhawk/Doom3 is a different path than /home/sparhawk/doom3). Windows does not have such restrictions but it happened on some systems that there were still issues with paths, as Doom 3 has it's own internal library of handling paths in a system independent way and therefore this might cause maps to break on some systems while they can work on others.
+
It is recommended that the installation path for Doom 3 contains no blanks as it might cause problems with some of the tools. Additionally it is recommended to keep all the paths lower case. This is especially important as Doom 3 can also run on other platforms like Linux where pathnames are different depending on their case (i.e. /home/sparhawk/Doom3 is a different path than /home/sparhawk/doom3). Windows does not have such restrictions but it happened on some systems that there were still issues with paths, as Doom 3 has its own internal library of handling paths in a system independent way and therefore this might cause maps to break on some systems while they can work on others.
  
 
Depending on the operating system additional requirements may apply. Doom 3 currently supports Windows, Linux and Mac platforms. Requirements for the various platforms will be added at a later point, when development has progressed to a state where it makes sense to ensure platform compatibillity.
 
Depending on the operating system additional requirements may apply. Doom 3 currently supports Windows, Linux and Mac platforms. Requirements for the various platforms will be added at a later point, when development has progressed to a state where it makes sense to ensure platform compatibillity.
Line 13: Line 13:
  
 
===Install on Linux===
 
===Install on Linux===
Instructions on how to install The Dark Mod on linux will be added at a later point, as currently there is no development done to ensure linux compatibillity.
+
 
 +
You need the native version of Doom 3 installed and patched to v1.3.1. Download
 +
[http://zerowing.idsoftware.com/linux/doom/ here].
 +
 
 +
On 64 bit systems, you also need the 32 bit compatibility libraries installed. On SuSE, these are included in the default installation, but on Kubuntu/Ubuntu you need to install the package called <code>ia32-lib</code> and all its dependecies. Otherwise, even the installer for Doom 3 will fail to run.
 +
 
 +
Instructions on how to install The Dark Mod on Linux will be added at a later point.
  
 
== Running the Mod ==
 
== Running the Mod ==

Revision as of 18:35, 5 October 2007

Requirements

In order to install The Dark Mod, you need to have the 1.3.1 patch for Doom 3 installed. You can download the patch for Windows here.

It is recommended that the installation path for Doom 3 contains no blanks as it might cause problems with some of the tools. Additionally it is recommended to keep all the paths lower case. This is especially important as Doom 3 can also run on other platforms like Linux where pathnames are different depending on their case (i.e. /home/sparhawk/Doom3 is a different path than /home/sparhawk/doom3). Windows does not have such restrictions but it happened on some systems that there were still issues with paths, as Doom 3 has its own internal library of handling paths in a system independent way and therefore this might cause maps to break on some systems while they can work on others.

Depending on the operating system additional requirements may apply. Doom 3 currently supports Windows, Linux and Mac platforms. Requirements for the various platforms will be added at a later point, when development has progressed to a state where it makes sense to ensure platform compatibillity.

Installing The Dark Mod

Install on Windows

In order to install The Dark Mod, once the requirements have been satsified, you should download the package which is provided (insert link here). In the distribution is a DLL contained named DevIL.dll which is required for image handling. Since as the time of writing there is no installer, so the user must install this library himself. To do this the DLL must be copied in the windows/system32 directory. The DLL can also be put in any other directory where a path is pointing to (meaning that the directory is included in the PATH environment variable when Doom 3 is run). If the library is not found when the mod is loaded, Doom 3 will show it's blue window and can not be started. The downloaded archive must be extracted directly into the Doom 3 folder which will create a darkmod folder in there with all files neccessary to run the mod.

Install on Linux

You need the native version of Doom 3 installed and patched to v1.3.1. Download here.

On 64 bit systems, you also need the 32 bit compatibility libraries installed. On SuSE, these are included in the default installation, but on Kubuntu/Ubuntu you need to install the package called ia32-lib and all its dependecies. Otherwise, even the installer for Doom 3 will fail to run.

Instructions on how to install The Dark Mod on Linux will be added at a later point.

Running the Mod

(It is assumed that running a mod is consistent throughout the supported platforms. In case this turns out not to be true, we will add specific instructions for certain platforms later.)

Loading the mod manually

In order to run The Dark Mod, Doom 3 can be started normally. In the lower right corner you can see a button saying "MOD". Clicking on this button will cause a dialog to appear listing all the mods currently installed. You can select Darkmod by choosing the appropriate entry from the dialog and load it. This will cause Doom 3 to load the mod data and initialze the mod. For later releases it is planned to create a total conversion, which means that we will provide menu screens for all the various settings to be done in a consistant style fitting to the The Dark Mod universe. Since this is still under development, TDM maps have to be loaded via console commands using "map <mapname>". For instructions on how to use the console please refer to the game manual or tutorials which can be found (insert link to general tutorial site).

Using the command line or a shortcut (recommended)

Alternatively The Dark Mod can be initialized directly from the command line (or via a shortcut from the desktop) by using the commandline

  • Windows: "<path to Doom 3>/doom3.exe set fs_game darkmod"
  • Linux: "<path to Doom 3>/doom3 set fs_game darkmod"

It is recommended to use this way of running The Dark Mod, as it appears that Doom 3 will handle paths more consistently then loading the mod manually.

Important information

The current build of The Dark Mod is not compatible with Linux, because the lightgem and the enhanced keyboardhandler will have to be specially implemented for each platform. This is currently only available for MS Windows.

Performance Tweaks

To make TDM run a little bit faster:

  • Run it in fullscreen - about a 4fps increase.
  • Turn down anisotropic filtering (in DoomConfig.cfg), cos it defaults to 8. - ~1-2fps increase.

Here's to start. Of course there is the "Low/Medium/High/Ultra" settings, but those are obvious. (Note: Do NOT use "Ultra" graphics setting, as this will result in not being able to see many textures)